Won't build (fixture fabricator component

I placed a non-custom template and removed it cause it was in the wrong place. Then this error occured:

develop-3023 (x64)(M)
…onehearth/components/building/building_component.lua:176: attempt to index local ‘entry’ (a nil value)
stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:176: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:179: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:42: in function <…/fixture_fabricator/fixture_fabricator_component.lua:40>
Now my hearthlings won’t build anything. They don’t even recognise new templates. Using develop 3023 version.

does restarting the save or going back to an earlyer save fix anything?

Save/load does not fix the problem. I don’t have a save before the error happened, so I don’t know if it is a world corrupting error or just the save.

Actually found a previous save. And the bug is not present in that save.
Maybe this has something to do with it.

As you can see on the picture below, the template is placed so that it sticks 2 blocks out over an edge. When I remove the template, now this error occurs:

develop-3023 (x64)(M)
stonehearth/lib/player/territory.lua:89: attempt to call method ‘destroy’ (a nil value)
stack traceback:
[C]: in function ‘destroy’
stonehearth/lib/player/territory.lua:89: in function ‘remove_entity’
…nehearth/services/server/terrain/terrain_service.lua:161: in function <…nehearth/services/server/terrain/terrain_service.lua:149>
I don’t know if it is linked with the previous error or not.

develop-2924 (x64)

…onehearth/components/building/building_component.lua:154: attempt to index local ‘entry’ (a nil value)

stack traceback:

radiant/modules/common.lua:237: in function 'report_traceback’

radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>

…onehearth/components/building/building_component.lua:154: in function ‘get_dependencies’

…/fixture_fabricator/fixture_fabricator_component.lua:163: in function ‘_are_dependencies_satisfied’

…/fixture_fabricator/fixture_fabricator_component.lua:180: in function 'fn’

radiant/modules/events.lua:203: in function <radiant/modules/events.lua:200>

[C]: in function 'xpcall’

radiant/modules/common.lua:257: in function 'xpcall’

radiant/modules/events.lua:200: in function ‘trigger’

…onehearth/components/building/building_component.lua:607: in function ‘_on_child_finished’

…onehearth/components/building/building_component.lua:333: in function 'instance’

radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>

[C]: in function 'xpcall’

radiant/modules/common.lua:257: in function 'xpcall’

radiant/modules/events.lua:200: in function 'trigger’

radiant/modules/events.lua:241: in function '_fire_async_triggers’

radiant/modules/events.lua:319: in function '_update’

radiant/server.lua:62: in function <radiant/server.lua:58>

Welcome to the forum, @Girivardhan :slight_smile:
It looks like you have an outdated version of the game. If you did not buy it in Steam, you can login into your Humble Bundle account and download the latest stable version (A17 r593). If you bought it via Steam it should have already auto-updated :confused: