Why is my Wix site not showing up in Google?

Go to Settings in your site’s dashboard. Click the SEO tab. Scroll down to SEO Status. Click the Allow search engines to include your site in search results toggle to enable this option.

For More Information Please Refer: https://support.wix.com/en/article/enabling-search-engines-eg-google-to-find-your-site