Unable to create search index

Hi Guys,
we installed elasticsearch on Cent OS in Version 5.6.5 with mapper plugins.

After A reboot we had some Troubles to get the Service startet, this is fixed.

Unfortunately we can not create a Index.

We always get the following error:

Unable to process PUT at http://localhost:9200/_ingest/pipeline/zammad-attachment
Error is still the same if we use http://fqn:9200 or localhost or IP Adress.

firewalld is configured Port ist open.
CUrl Shows the following

{
"name" : "fthmWhb",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "sqj3B91DT6ujXjnubp7dgw",
"version" : {
"number" : "5.6.5",
"build_hash" : "6a37571",
"build_date" : "2017-12-04T07:50:10.466Z",
"build_snapshot" : false,
"lucene_version" : "6.6.1"
},
"tagline" : "You Know, for Search"
}
I don`t know how to fix this, can anyone help?

You need to share what you are exactly doing. What are the commands you are sending?
Please use </> to format your code and not the citation icon.

Hi Thanks for your answer:
zammad run rails r “Setting.set(‘es_url’, ‘http://localhost:9200’)”

zammad run rake searchindex:rebuild --trace

Result:

** Invoke searchindex:rebuild (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute searchindex:rebuild
** Execute searchindex:drop
drop indexes...
** Execute searchindex:create
create indexes...
rake aborted!
Unable to process PUT at http://localhost:9200/_ingest/pipeline/zammad-attachment
#<UserAgent::Result:0x00555c688ee8c8 @success=false, @body=nil, @data=nil, @code="400", @content_type=nil, @error="Client Error: #<Net::HTTPBadRequest 400 Bad Request readbody=true>!">
/opt/zammad/lib/search_index_backend.rb:95:in block (2 levels) in processors' /opt/zammad/lib/search_index_backend.rb:62:ineach'
/opt/zammad/lib/search_index_backend.rb:62:in block in processors' /opt/zammad/lib/search_index_backend.rb:59:ineach'
/opt/zammad/lib/search_index_backend.rb:59:in processors' /opt/zammad/lib/tasks/search_index_es.rake:68:inblock (2 levels) in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:in block in execute' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:ineach'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:in execute' /opt/zammad/lib/tasks/search_index_es.rake:121:inblock (2 levels) in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:in block in execute' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:ineach'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:251:in execute' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:195:inblock in invoke_with_call_chain'
/opt/zammad/vendor/ruby-2.4.1/lib/ruby/2.4.0/monitor.rb:214:in mon_synchronize' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:188:ininvoke_with_call_chain'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/task.rb:181:in invoke' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:160:ininvoke_task'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:116:in block (2 levels) in top_level' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:116:ineach'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:116:in block in top_level' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:125:inrun_with_threads'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:110:in top_level' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:83:inblock in run'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:186:in standard_exception_handling' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/lib/rake/application.rb:80:inrun'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/rake-12.3.0/exe/rake:27:in <top (required)>' /opt/zammad/vendor/bundle/ruby/2.4.0/bin/rake:22:inload'
/opt/zammad/vendor/bundle/ruby/2.4.0/bin/rake:22:in <top (required)>' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:74:inload'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:74:in kernel_load' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli/exec.rb:27:inrun'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:360:in exec' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/command.rb:27:inrun'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in invoke_command' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor.rb:369:indispatch'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:20:in dispatch' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/vendor/thor/lib/thor/base.rb:444:instart'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/cli.rb:10:in start' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/exe/bundle:35:inblock in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/lib/bundler/friendly_errors.rb:121:in with_friendly_errors' /opt/zammad/vendor/bundle/ruby/2.4.0/gems/bundler-1.15.1/exe/bundle:27:in<top (required)>'
/opt/zammad/bin/bundle:3:in load' /opt/zammad/bin/bundle:3:in'
tail -f /var/log/elasticsearch/elasticsearch.log
[2018-01-15T18:07:55,637][DEBUG][o.e.a.b.TransportBulkAction] [fthmWhb] failed to execute pipeline [zammad-attachment] for document [aitservice.ait.local_zammad_production/User/856]
java.lang.IllegalArgumentException: pipeline with id [zammad-attachment] does not exist
at org.elasticsearch.ingest.PipelineExecutionService.getPipeline(PipelineExecutionService.java:194) ~[elasticsearch-5.6.5.jar:5.6.5]
at org.elasticsearch.ingest.PipelineExecutionService.access$100(PipelineExecutionService.java:41) ~[elasticsearch-5.6.5.jar:5.6.5]
at org.elasticsearch.ingest.PipelineExecutionService$2.doRun(PipelineExecutionService.java:88) [elasticsearch-5.6.5.jar:5.6.5]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:638) [elasticsearch-5.6.5.jar:5.6.5]
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) [elasticsearch-5.6.5.jar:5.6.5]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_151]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_151]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]

Please use </> to format your code and not the citation icon.

pipeline with id [zammad-attachment] does not exist`

Sounds like your pipeline has not been created.
Again, I have absolutely no idea of what you are doing.
I don’t know what means:

zammad run rails r "Setting.set('es_url', 'http://localhost:9200')"
zammad run rake searchindex:rebuild --trace

Might be an application… But don’t know what it is and what it does.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.