Twitter API usage error

I was constantly using the Twitter login API, but suddenly it was disabled. The error message is ‘com.github.scribejava.core.exceptions.OAuthConnectionException: There was a problem while creating a connection to the remote service: https://api.twitter.com/oauth/request_token’.

If you have experienced the same situation, please reply.

Thanks

What date did this start happening? Could this be to do with the recent change to require TLS 1.2?
What version of Java are you using?

Hello? Please understand that I am not familiar with English. I’ll answer you.

  1. What date did this start happening?
A. We haven’t confirmed the exact date, but from August we have confirmed that
  1. Could this be to do with the recent change to require TLS 1.2?
A. No recent changes have been made to the Twitter API. I’m using scribejava-apis-3.3.0.jar and scribejava-core-3.3.0.jar as libraries. 3.What version of Java are you using? A. The version of JAVA I am using is 1.7.0_79. Currently-APP created with the same account APP ID 14181842 (URL : http://14.63.183.167:7080/) can be used normally. But other apps are not available. We have answered your question and would like to receive additional information.
Thank you. 2019년 8월 27일 (화) 오후 6:56, Andy Piper via Twitter Developers mailto:jeevith@dev.mpl.co님이 작성:

You’re using Java 7, where the default is TLS 1.0. Java 8 defaults to TLS 1.2
My suggestion is that your issue is tied to the changeover to TLS 1.2.

Hello?

Thank you for your answer.
I have a question about your reply mail.
So, do I have to upgrade to Java 8 version to use the Twitter API from now on?
2019년 8월 28일 (수) 오전 10:40, Andy Piper via Twitter Developers mailto:jeevith@dev.mpl.co님이 작성:

We are unable to tell you that a specific Java version will work. I can tell you that about 3 weeks ago we required TLS 1.2 for secure connections.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.