Mountain's Windchime bug in Alpha 17 593

So, hi. I’m new here. So far, I didn’t see any mention of this bug, but I just ran into it. I hope this info is helpful.
Summary:

Mountain’s Windchime ignores placement command if it’s in a Vault. (Any storage chest?)
Steps to reproduce:

  1. Make the Mountain’s Windchime.
  2. Put it in the Vault storage item.
  3. Tell a Hearthling to place it.
  4. Watch all the Hearthlings ignore the placement command for 24 in-game hours.
  5. Filter the Vault so that the Mountain’s Windchime is placed on an open stockpile zone.
  6. Watch the Hearthling pick up the Mountain’s Windchime from the open stockpile and place it just fine within about 1/2 of an in-game second.
Expected Results:
You tell the Hearthlings to place the Mountain’s Windchime, and they just go get it wherever it is and do it. Actual Results:
The Hearthlings ignore the placement command for the Mountain’s Windchime until you trick them into removing it from the Vault and moving it to an open stockpile. Notes:
Needs more testing to determine if the Vault item itself is the issue or if it is removing the Mountain’s Windchime from any storage item that is the problem. Attachments:
I can provide a save file if that is deemed necessary. I assume it will be easy to reproduce.
Version Number and Mods in use: System Information:
Can be provided if it seems relevant to devs. Thanks,
~Vay

Did you try to place it using the placement UI? §
You can’t click on a storage invertory and place it, if it was happening with the placement UI, well that’s an odd bug(and a critical one)

It was happening with the placement UI.
Just as with any chair or bed, the ghost-image of the new location for the Mountain’s Windchimes was present in the world, but no Hearthling would actually place it until I forced it out of the Vault.