Logstash with Google Pub/Sub

Hi All
I’m want to use logstash-input-google-cloud-pubsub as input for logstash 2.2.2.

All my tries to run it have failed so far.
Installing out of the box gives me an dependency error

gcloud 0.6.1 requires Ruby 2.0
Installing in jruby compatability mode "JRUBY_OPTS=--2.0" was success but failed at startup:
./bin/logstash -f /home/me/dev/proj/deployment/logstash/pipeline.conf
SyntaxError: /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.6.1/lib/gcloud.rb:113: syntax error, unexpected tLABEL
  def datastore scope: nil
                      ^
     require at org/jruby/RubyKernel.java:1040
     require at /opt/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65
      (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-google-cloud-pubsub-2.0.2/lib/logstash/inputs/google_cloud_pubsub.rb:1
     require at org/jruby/RubyKernel.java:1040
     require at /opt/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65
      (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-google-cloud-pubsub-2.0.2/lib/logstash/inputs/google_cloud_pubsub.rb:2
      (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/plugin.rb:1
      lookup at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/plugin.rb:80
        eval at org/jruby/RubyKernel.java:1079
      plugin at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/pipeline.rb:400
  initialize at (eval):7
  initialize at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/pipeline.rb:57
        call at org/jruby/RubyProc.java:281
     execute at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/agent.rb:172
        call at org/jruby/RubyProc.java:281
         run at /opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.2-java/lib/logstash/runner.rb:90
Installing version pinned to gcloud 0.5 succeeded. However trying to run it failed with the following:
./bin/logstash -f /home/me/dev/proj/deployment/logstash/pipeline.conf
google_cloud_pubsub plugin doesn't have a version. This plugin isn't well
 supported by the community and likely has no maintainer. {:level=>:warn}
elasticsearch: unknown error {:class=>"Manticore::ResolutionFailure", :level=>:error}
elasticsearch {:class=>"Manticore::ResolutionFailure", :level=>:error}
elasticsearch {:class=>"Manticore::ResolutionFailure", :level=>:error}
elasticsearch {:class=>"Manticore::ResolutionFailure", :level=>:error}
Settings: Default pipeline workers: 4
SyntaxError: /opt/logstash/vendor/bundle/jruby/1.9/gems/jwt-1.5.3/lib/jwt/verify.rb:7: unknown type of %string
      %i[verify_aud verify_expiration verify_iat verify_iss verify_jti verify_not_before verify_sub].each do |method_name|
        ^
  require at org/jruby/RubyKernel.java:1040
  require at /opt/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/jwt-1.5.3/lib/jwt/decode.rb:1
  require at org/jruby/RubyKernel.java:1040
  ...
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud/pubsub/connection.rb:17
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud/pubsub/project.rb:1
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud/pubsub/project.rb:17
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud/pubsub.rb:1
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud/pubsub.rb:17
     call at org/jruby/RubyProc.java:281
   (root) at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud.rb:1
     call at org/jruby/RubyProc.java:281
   pubsub at /opt/logstash/vendor/bundle/jruby/1.9/gems/gcloud-0.5.0/lib/gcloud.rb:206
Does Somebody already use it?
Can you please share your experience of how do you run it exactly? Thanks a lot,
Ilya

The issue was resolved.


thanks.