Kingdom Power Levels Not Updating (Resolved)

Kingdoms not updating power levels with prerequisites filled. Troops are all level 10, but kingdoms not upgrading. Screenshot of one kingdom example.

Can you also show the kingdom screen? Have you tried restarting the game? There are a lot of things in the game that sometimes magically update if you restart.
(The explanation there is a lot of stuff updates based on when certain data files are downloaded, but the game is sometimes stingy about when it downloads them to save on data/load times.)

Yeah, I tried to attach to screenshots. However, new members can only post one image. Forgot to add it in a follow up reply.
Restarted and everything. Not updating the relevant power levels.

Is your VIP level 8 or higher? I could possibly imagine the auto-boost to troop level 10 not triggering power levels correctly.

Maybe try upgrading one of them to level 11?

Yes, I’m at VIP 8, that could have been the issue. I don’t know what has happened since my last response, but the issue has since been fixed. Cheers everyone for your help.

Hey Brownbear, sorry for the delay - we are working through a rare backlog. That was unusual but I’m glad it’s working now!