Issues connecting to logstash on windows server

Hi, I am new to ELK world and started installing ELK stack… elasticsearch and Kibana are up and running and am able to login using the localhost url, but having issues while connecting to logstash… pls help

0x7cc3f2f3 run>"}
[2018-01-10T18:36:35,008][INFO ][logstash.licensechecker.licensereader] Elasticsearch pool URLs updated {:changes=>{:rem
oved=>[], :added=>[http://localhost:9200/]}}
[2018-01-10T18:36:35,008][INFO ][logstash.licensechecker.licensereader] Running health check to see if an Elasticsearch
connection is working {:healthcheck_url=>http://localhost:9200/, :path=>"/"}
[2018-01-10T18:36:35,023][WARN ][logstash.licensechecker.licensereader] Attempted to resurrect connection to dead ES ins
tance, but got an error. {:url=>"http://localhost:9200/", :error_type=>LogStash::Outputs::ElasticSearch::HttpClient::Poo
l::BadResponseCodeError, :error=>"Got response code '401' contacting Elasticsearch at URL 'http://localhost:9200/'"}
Got response code '401' contacting Elasticsearch at URL 'http://localhost:9200/_xpack'
[2018-01-10T18:36:35,070][ERROR][logstash.licensechecker.licensemanager] Unable to retrieve license information from lic
ense server {:message=>"Got response code '401' contacting Elasticsearch at URL 'http://localhost:9200/_xpack'", :class=
[2018-01-10T18:36:35,070][WARN ][logstash.licensechecker.xpackinfo] Nil response from License Server
[2018-01-10T18:36:35,148][INFO ][logstash.pipeline        ] Pipeline started {""=>".monitoring-logstash"}
[2018-01-10T18:36:35,258][INFO ][logstash.agent           ] Pipelines running {:count=>1, :pipelines=>[".monitoring-logs
[2018-01-10T18:36:35,273][ERROR][logstash.inputs.metrics  ] Monitoring is not available: License information is currentl
y unavailable. Please make sure you have added your production elasticsearch connection info in the xpack.monitoring.ela
sticsearch settings.
[2018-01-10T18:36:36,367][INFO ][logstash.pipeline        ] Pipeline terminated {""=>".monitoring-logstash"}

Looks like you have to install x-pack on ES too and you need to turn ssl on.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.