Elastic password reset error -

I am followng the below answer to reset the elastic password.

{“error”:{“root_cause”:[{“type”:“unavailable_shards_exception”,“reason”:"[.security-6][0] [1] shardIt, [0] active : Timeout waiting for [1m], request: indices:data/write/update"}],“type”:“unavailable_shards_exception”,“reason”:"[.security-6][0] [1] shardIt, [0] active : Timeout waiting for [1m], request: indices:data/write/update"},“status”:503}
But I am getting above error when i try to reset the password.
I have one master node where we have configured xpack and two data nodes which doesnt have xpack installed.
On trying to reset the password using interactive command(bin/x-pack/setup-passwords interactive) it throws below error
Failed to authenticate user ‘elastic’ against http://localhost:9200/_xpack/security/_authenticate?pretty

Possible causes include:
The password for the ‘elastic’ user has already been changed on this cluster

Your elasticsearch node is running against a different keystore

This tool used the keystore at /etc/elasticsearch/elasticsearch.keystore

Also we are not able to create any role using created my_admin user for ldap authentication.

There’s something wrong with your cluster.

Either you have missing data (shards) or you have nodes that aren’t responding to requests, or something like that.

This isn’t specifically a security problem, it’s occurring whenever X-Pack tries to read or write to the security index, but it would probably also happen for other indices.
When you start up Elasticsearch, it should be telling you that it is on RED state because some shards aren’t available.
What’s the history with this cluster? Can you tell us how you got into this state?

Hi Tim
We have three nodes, one master and two data nodes. All shards failed when we install x-pack in all the nodes.
“cluster.routing.allocation.enable” property on default changed to “none” from “all”, when we restarted all the nodes.
When we tried to change it “all” we faced the authentication problem and even default “changeme” password doesnt work because of shard failure.
On disabling x-pack all shards came up and all worked fine.

How do fix the issue of shard failure on installing xpack.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.