Can't see all fields after importing sample dataset but I can query

Hello,
I imported the bank accounts sample dataset (accounts.json) successfully into elastic 5.6.4 then I created my index pattern as ba*
Now in the discover tab, I can do queries like (account_number:<100 AND balance:>47500) and I get the correct amount of results but I dont see except the fields that begin with _
Here is a screenshot


Same result even when I do match queries in curl (totally independent of kibana). Please let me know what I’m doing wrong… why is _source empty? Im sure all the fields/values got copied to ES but I can’t view them.
Curl example

curl test:9200/bank/account/_search?q=Putnam

{“took”:0,“timed_out”:false,"_shards":{“total”:5,“successful”:5,“skipped”:0,“failed”:0},“hits”:{“total”:1,“max_score”:4.6146765,“hits”:[{"_index":“bank”,"_type":“account”,"_id":“25”,"_score":4.6146765,"_source":{}}]}}
GET /bank/_mapping

Can you refresh your index pattern? What happens?

Hi val,
Thanks for the quick reply. I tried to refresh the index pattern from the following page


And I also restarted elastic and kibana just to make sure… but that made no difference, I still have the same view in the screenshot in my first post. I’ve been trying to figure out what I’m doing wrong for the past 3 hours with no luck. Thank you.
edit: one thing to note, in the discover tab of kibana, under Available fields… if i uncheck ‘Hide Missing Fields’ then it shows me the field names like balance, etc… but still the _source is empty and no content is shown

Can you show how you imported the accounts.json file into ES?

You should not define _source settings in your mapping.