Atom eats my CPU

Immediately after atom start top shows me 110%-130% CPU loading and in 2-3 minutes system becomes unresponsive. Also i can view heavy disk load.
These hasn’t any effect:

  • Removing ~/.atom
  • Call ‘atom --safe’
What works: kill wrong process. After that editor still working ok (until restart). If i open new tab (by Ctrl-t) i see “indexing projects…” and new hungry process appears. Linux Ubuntu x86_64, i7, 4Gb, 1280*800.
Atom 0.920.0 from .deb package. This process does it (ps output):
fenrir   11547  120 11.9 1299556 460008 ?      Rl   12:40   0:41 /usr/share/atom/atom --eval require('/usr/share/atom/resources/app/node_modules/coffee-cash/lib/coffee-cash.js').setCacheDirectory('/home/fenrir/.atom/compile-cache/coffee'); require('/usr/share/atom/resources/app/node_modules/coffee-cash/lib/coffee-cash.js').register(); require('/usr/share/atom/resources/app/node_modules/coffeestack/index.js').setCacheDirectory('/home/fenrir/.atom/compile-cache/coffee/source-maps'); require('/usr/share/atom/resources/app/src/task-bootstrap.js');
similar to it, but no MacOS. Hope for your help)

Are you using a hard drive or SSD as your main drive? This is almost assuredly caused by one of two things, both of which are mentioned at some point in the other topic:

  1. Atom consists of lots of JavaScript files that have to be read in on load. This can be slow and CPU heavy on HDs.
  2. If you’re launching Atom from your $HOME directory, Atom indexes the file structure of everything under the home directory and watches files for changes … this can also be CPU heavy
The first cause is being addressed in v0.193.0 by: The second can be handled by not launching Atom from the home directory.

There have been numerous reports with similar output pointing at the eval with coffee-cash.

Personally, I haven’t seen this extreme resource consumption, on recent versions or otherwise, but then again I haven’t been on HDDs for a while.
Not that an editor should require such high disk I/O on startup. I’m looking forward to what the asar format will do.

I have sdd in my laptop but it’s very similar to indexing. How can I disable this behavior?

Thanks, obviously it’s my case

Getting the same issue here, fresh Atom install is eatting up all cpu and memory within the first few minutes of starting. I find it hard to believe this is an issue with Atom watching the home directory. For example the issue only happens when launching in the /home or /home/USER directories, if I launch from the systems root directory or anywhere else it’s fine.
Also if I pass Atom a file to open on launch the issue doesn’t appear. So I can launch from the home directory with “atom untitled” and everything ends up fine.

Do you have symbolic links that can create circular references under your home directory? Launching from the system root, indexing could be blocked by lack of permissions at some intermediate step.

No symbolic links that I know of are creating a circular reference. There shouldn’t be, but just to be safe is there an efficient way to look for any?
I was wrong about the system root it only managed to launch once there without memory piling up. The memory leaking happens everywhere, unlike I originally thought, but it does take much longer in smaller folders (about an hour to get to 1 gigs as opposed to 5 minutes to get to 2 gigs). I was also wrong about passing any file into atom, it has to be a non existent file otherwise coffee cache still leaks. Seems strange that would work, but it does as far as I can tell.

Hi, I have a similar problem on my Thinkpad t440p (core-i5, 8 GB RAM, SDD, running LinuxMint 17.01) - on launch Atom (v. 0194) consumes both memory and CPU like a hungry dragon - the memory goes over 2 GB in about a minute, and CPU consuption is around 100% on one thread, and about 20% on another.
Following the hint by greyfenrir I killed one of the 3 Atom processes appearing after launching the program, and both memory and cpu went back to normal (i.e. about 50 MB). So, obviously Atom starts some crazy proces on startup, which sets about killing the host computer :smile: . It seems to happen at every startup. Would be great if this behaviour was corrected in a future version.
Otherwise, I love Atom.

Hey Folks ,

i’m facing same error and problem on my CPC ; I love to use atom text editor

because of this issue i’m not able to use it

please give me proper soultion

I still experience the same problem, and I have an SSD.