Ambitious Building Crashes Silently

I wanted to stress-test the building editor in r572(x64). So I did a ton of crazy things. Walls against a cliffside, slabs against walls pillars, slabs on the roof, stairs doing something completely non-stair-like, a floor on a roof [with a hand-drawn roof because the roof tool refused to do that]. It was a bit of effort, because I had to draw slabs out from the walls to connect everything on the roof or else it would become a different building.
I ended up with this template: template.zip (55.7 KB)



[Wow. The template pictures look really cool now.]
I made sure to save right before building: save.zip (4.6 MB),

and after I tried again, it built to about here again smoothly, if with a floating roof for a while:so close.zip (5.6 MB)
The next morning, they go back to work, build up the scaffolding a bit, and then the game crashes silently.
I copied the log file today, right before I launched SH to test a second time: stonehearth.log (1.3 MB)
Stonehearth also seems prone to crashing on me in general these days; it really doesn’t like me coming back after an alt+tab when it’s in fullscreen mode.
Is there any other information I need to give?
I thought I was playing without mods, but I do seem to still have old versions of homf and lomc in the mods folder. Could those be causing a problem somehow?

old mods can mess everything up, I would say update to their most recent, or delete altogether.

Now that I know they’re there [I thought I cleared them out ages ago], my old mods are gone. I guess I have to try again.
Now my Hearthlings merely stop building entirely shortly after where the game originally crashed.
Alt+Tab works again, at least.
Scratch that, it doesn’t. It did a few times, then I hit alt+tab again to type this out, then the game switched to night [or at least I heard the night music begin] and crashed right after that. May still have been the building, though?
Here’s the log after that crash: stonehearth.log (61.2 KB)

Hi,

If you have the crash.dmp for the crash, that would be very helpful. (it will be in the same folder as the stonehearth.log)

Thanks

-Yang

I don’t know how I didn’t notice that file earlier. Here you go!:crash.dmp (191.3 KB)

Thanks!

It looks like a crash in atio6axx.dll

which is the AMD OpenGL driver

There was someone else who had the same issue, here:


Did you update your graphics driver recently? If so, the person in that thread had to do an uninstall and reinstall of the driver to fix the crashing :frowning:

Let me know if this helps

Thanks

-Yang

Okay, I should have never messed with my drivers. For the life of me, I can’t find out how to reinstall OpenGL drivers. Downloading the new software just brings me to a link to update my drivers, except that links right to where I downloaded the software,
I give up. I’ll probably just try to buy a new graphics card in a few weeks anyway.

Okay, I’ve finally gotten OpenGL reinstalled and I can finally play Stonehearth again! I’m kind of too scared to try again.
Also, now I’m under a brownout. But I’ll try again soon.

Stonehearth is no longer crashing on me, so we’re just stuck with a regular “buildings my Hearthlings won’t build” situation, which, to be fair, I mostly expected.

glad to hear the crashing is fixed for you @Rajeshwari :smile: i’ll move this thread to resolved.